AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
21.01.19 - 19:49:51
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 8
| |-+  ND8: Administration & Userprobleme (Moderatoren: Axel, Thomas Schulte, koehlerbv)
| | |-+  Notes2.exe beendet sich beim Client- Start -ohne Log und ohne coredump
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: Notes2.exe beendet sich beim Client- Start -ohne Log und ohne coredump  (Gelesen 2228 mal)
Tode
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 6122


Geht nicht, gibt's (fast) nicht... *g*


« am: 23.01.12 - 14:09:10 »

Ich habe hier einen 8.5.3- Client der sich nicht mehr starten lässt:

Die Anmeldung kommt, aber noch während des Anmeldeprozesses (wenn man nicht schnell genug tippt) verabscheidet sich die notes2.exe aus dem Task- Manager.
Dann bekommt man den -wohl jedem bekannten- Dauer- Ladebalken...

Ich habe alle mögliche Probiert, um dann festzustellen, dass es am Lotus\Notes\framework- Verzeichnis liegt.
Wenn man das von einem anderen PC kopiert, dann startet der Client wieder.

Und umgekehrt: Kopiert man dieses Verzeichnis in einen funktionierenden Client, dann startet der auch nicht mehr.

Da ich wissen will WARUM dieses Framework- Verzeichnis nicht funktioniert, versuche ich das grade nachzustellen.
Habe jetzt erst mal einen Verzeichnis- Vergleich gemacht, und bin dran die überzähligen Verzeichnisse rauszuschieben.
Danach kommt dann der Datei- Vergleich (wenn das nix hilft).

Hat jemand ne Idee, wo ich nmachlesen könnte, WARUM sich die notes2.exe beendet?

Normalerweise kriegt man in dem Fall ein Java- Coredump im workspace- Verzeichnis des Clients... in diesem Fall leider nicht.
Wo könnte das Log sonst noch geschrieben werden?

Sonst suche ich mich bei 20.000 Dateien in 2.500 Ordnern ja zu Tode...

Warum ich das wissen will: Das ganze passierte bei 2 von 3 Test- Pilot- Systemen, die wir von 8.5.2 auf 8.5.3 aktualisiert haben, und ich würde gerne die Ursache finden, bevor wir 2.000 User updaten und dann dort regelmässig das framework- Verzeichnis zerschiessen...
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Tode
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 6122


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #1 am: 26.01.12 - 14:43:13 »

Dann antworte ich mir mal selbst...

WARUM das ganze passiert ist, weiss ich nach wie vor nicht. Aber: Die Ursache war eine fehlerhafte install.xml im Verzeichnis
Lotus\Notes\framework\rcp\deploy

Diese Datei enthielt
- Verweise auf eine alte 8.5.1- Installation, die von einem Netzlaufwerk gestartet worden war
- Doppelte Verweise auf diverse Features mit unterschiedlichen Versionsständen

Ausserdem enthielt die rcplauncher.properties einen Verweis auf einen Workspace- Folder aus einer alten Installation, so dass der nicht dort angelegt wurde, wo ich ihn erwartet habe, und deshalb habe ich auch keine Logs gefunden...

Diese Infos muss ich jetzt unbedingt niederschreiben, damit ich das nächste Mal wieder zwei Dateien mehr habe, in denen ich nachschauen kann...

Bestätigt übrigens das, was ich schon oft gehört habe und auch selbst predige: NIEMALS 8er Versionen updaten... Immer erst deinstallieren, Programmverzeichnis wegschmeissen (data darf man behalten) und neu installieren... Sonst holt einen das irgendwann mal ein...

Ach ja: Dass in der Install.xml ein Verweis auf das Netzlaufwerk drin war, von dem der Client ursprünglich mal installiert wurde (und er auch versucht, das zuzugreifen), lässt mich im umkehrschluss darauf schliessen, dass ein erneutes Provisioning NIE funktionieren wird, wenn man unterwegs ist und ursprünglich die Software von einem Netzlaufwerk aus installiert wurde... Aber das wäre noch zu beweisen.
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: