Autor Thema: Agent "After new mails has arrived"  (Gelesen 1597 mal)

Offline tfrenz

  • Aktives Mitglied
  • ***
  • Beiträge: 233
  • Geschlecht: Männlich
Agent "After new mails has arrived"
« am: 01.08.20 - 13:41:27 »
Hallo, ich weiss nun nicht genau, ob es ein Entwicklungs Thema oder ein Administrations Tehma ist.
Ein Agent soll Nach dem eine neue Mail in einer Mail-In Datenbank loslaufen.
Mache ich das mit dem Administrator Account funktiniert es auch.
Signiere ich nun die DB mit der Server ID, das auch der Agent mit der Server ID Signiert ist, funktioniert es nicht mehr.

Es konnt im Log nur:
[1F20:0002-0A08] 01.08.2020 13:22:55   AMgr: 'Server/SRV/XXX' is the agent signer of agent 'ImportEMail agImportEMail' in 'TEST\TESTImport.nsf'
[1F20:0002-0A08] 01.08.2020 13:22:55   AMgr: 'Agent 'ImportEMail agImportEMail' in 'TEST\TESTImport.nsf' will run on behalf of 'Server/SRV/XXX'
[1A70:0002-200C] 01.08.2020 13:23:51   AMgr: Agent 'ImportEMail agImportEMail' in 'TEST\TESTImport.nsf' ran successfully; elapsed time was '0' ticks

Kann mir hier jemand weiterhelfen?

Danke Thomas
Gruß
Thomas

Offline Tode

  • Moderator
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.723
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Re: Agent "After new mails has arrived"
« Antwort #1 am: 01.08.20 - 15:41:18 »
Die Sache hat damit zu tun, dass der Owner eines Mail- getriggerten Agenten bestimmt, wo der Agent läuft... ein Server hat aber keinen „Homeserver“, deshalb geht das schief. Setze mal die notes.ini- Variable Amgr_DisableMailLookup=1

Dann sollte der agent auch laufen wenn er mit dem Server signiert ist. Genauere Erklärungen und agent- debugging- tipps findest Du hier
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Offline tfrenz

  • Aktives Mitglied
  • ***
  • Beiträge: 233
  • Geschlecht: Männlich
Re: Agent "After new mails has arrived"
« Antwort #2 am: 02.08.20 - 11:48:35 »
Hallo Torsten,
danke mit dem Notes.ini Befehlt hat es nun funktioniert.
Gruß Thomas
Gruß
Thomas

 

Impressum Atnotes.de  -  Powered by Syslords Solutions  -  Datenschutz