AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
23.09.20 - 07:24:13
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Domino 8 und frühere Versionen
| |-+  ND7: Administration & Userprobleme (Moderatoren: eknori, koehlerbv, m3)
| | |-+  Invalid URL Exception bei www_01.css und Grafiken aus RTF
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: Invalid URL Exception bei www_01.css und Grafiken aus RTF  (Gelesen 2775 mal)
jww
Aktives Mitglied
***
Offline Offline

Geschlecht: Männlich
Beiträge: 180


« am: 11.04.20 - 18:16:09 »

Hallo,

ich bekomme seit ein paar Stunden folgende Fehlermeldung(en) - ohne dass ich irgend etwas am Domino Server geändert hätte. Ich habe inzwischen herausgefunden, dass es irgend etwas mit den Grafiken zu tuan haben muß (per paste in ein Body-RTF eingefügt) sowie mit Ressource, z.B. der WW_01.css.

Folgender Fehler kommt:

HTTP Web Server: Invalid URL Exception [/www/sub/dbname.nsf/$view/www?OpenDocument/sub/dbname.nsf/www_01.css]

und, je Grafik einmal:

HTTP Web Server: Invalid URL Exception [//www/sub/dbname.nsf/$view/www?OpenDocument/sub/dbname.nsf/b42aea8d1ca14048412567330028ae7a/4a39a0d044f764aec1258182002cb40d/Body/0.1538]

Der Fehler ist "plötzlich" und seltsamerweise auf zwei Servern aufgetaucht, die die DB'S miteinander replizieren - ohne dass ich (wissentlich) etwas gemacht hätte ...

Ich dachte erst, es käme nur von einer DB, aber nach tests muss ich sageN. Er kommt bei allen Datenbanken mit Dokumenten vor, die irgendwelche Grafiken im RTF haben.

Kann mir jeman einen Tip geben, was da faul sein kann?

1000 Dank im Voraus
jww

Gespeichert

Notes ist klasse - und ab und an zum auf den Mond schiessen.
jww
Aktives Mitglied
***
Offline Offline

Geschlecht: Männlich
Beiträge: 180


« Antworten #1 am: 28.04.20 - 18:13:34 »

Für den Fall, dass mal jemand denselben Fehler haben sollte:

Offenbar war das N&A fehlerhaft.

Ich habe:
- bei einem recht alten Backup auf eigenem Rechner festgestellt, dass alles geht.
- die fragliche (WEB-) DB dort eingebspielt ... keine Fehler
- Verdacht auf N&A (da der Fehler unmittelbar nacheinander auf zwei sich replizierenden Systemen auftrat)
- diese vom "defekten" auf den "alten" Server eingespielt: FEHLER.

Um ganz sicher zu sein, habe ich dann ein ganz abgestripptes "MINI-SYSTEM" aufgesetzt, auf dem nur extrem wenige, unbedingt notwendige Dateien waren;  selbst bei Systemrelevanten (Log etc) habe ich nur die NTF's belassen.

Ergebnis: Fehler immer nur mit dem fraglichen N&A, keine Fehler mit dem alten. egal, welche Web-DB. Weitere Prüfung: Bei Dokumenten, die nur Text beinhaltet haben, testweise ein JPG eingepastet: FEHLER. Und final: Mini-Web DB erstellt mit kaum Design elementen. "QPLain" Dokument angelegt, nur text: Kein Fehler. JPG eingefügt: FEHLER.

Neues N&A "from scratch" erstellt (aber die Dokumente des defekten N&A eingespielt). Ergebnis: KEINE Fehler mehr.

Es sieht für mich danach aus, dass die HTTP Task die NSF als "temporäres Verzeichnis" nutzt.

Denn ich habe dann mal die produzierten HTML Codes "guter" und der "defekter" Pages angesehen. Ergebnis: KEINS. Aber, und das hat mich zum Staunen gebracht: Die Source-Referenz zu den temporären Bildateien zeigt NICHT etwa in ein Temp Verzeichnis sondern in die NSF:

src="/www/xyz/NAMES_TEST.NSF/81893bdc6e30df53c12585490057893a/f11e472332c4262fc12585490057aeab/Body/0.108A?OpenElement&FieldElemFormat=gif"

Was mir völlig unbegreiflich ist, ist, warum nun eine defekte N&A bei dem obigen Element einen Fehler produziert.


« Letzte Änderung: 29.04.20 - 18:15:19 von jww » Gespeichert

Notes ist klasse - und ab und an zum auf den Mond schiessen.
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: