Autor Thema: [gelöst] Sametime 11: Moderne Clients aktualisieren Chatverlauf nicht  (Gelesen 2329 mal)

Offline Tode

  • Moderatoren
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.710
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Ich habe diese Frage schon im HCL Forum gestellt, aber dort wurde mir nur geraten, ein Ticket aufzumachen. Es kann doch nicht sein, dass es für so was "einfaches" nicht zumindest irgendwo Debug- Anweisungen oder Troubleshooting Tipps gibt.

Problem: Nachdem eine komplett neu aufgesetzte Sametime 11.0.1 Infrastruktur mit Sametime Server und Sametime Proxy anfangs (mehr oder weniger) einwandfrei funktioniert hat, funktionieren jetzt die "modernen" Clients alle nicht mehr, ohne dass ich mir einer Änderung bewusst bin:

Wenn ich im Webchat, im Sametime Embedded 11, HCL Sametime Connect Client oder am iPhone chatte, dann sehe ich weder den von mir gesendeten Text noch den eingegangenen Text.

Erst wenn ich den Chat komplett schliesse und neu öffne ist alles da, es geht also nichts verloren, ich sehe es nur nicht.
Mein Gegenüber mit Notes 9.0.1 und embedded Client sieht alles sofort und kann antworten.

Ich sehe sogar in meinem Client, wenn der andere tippt und mein Client blinkt bei Eingang eines neuen Chats, zeigt aber keinerlei Updates an.

Da das Problem sowohl über den Proxy (Webchat und iPhone) als auch direkt (Sametime Fat Client) auftaucht, würde ich -auch auf anraten aus dem HCL Forum- das Troubleshooting auf den Community- Server beschränken.
Ich habe -ebenfalls auf Tipp von dort- das Logging des stconvomap auf "FINEST" hochgedreht, aber nix in den stconvomap_YYYYMM_hhmm_0.txt- Dateien...

Ich habe sogar die gesamte Mongo- Installation zurückgesetzt und neu gemacht (es gibt da einen KB- Artikel zu), aber auch hier wieder: keinerlei Änderung.

Irgendjemand muss doch einen Tipp haben, wo und wie ich sowas Troubleshooten kann...

Ja, natürlich kann ich ein Ticket aufmachen, und das werde ich auch tun, aber trotzdem würde ich gerne vorher zumindest noch die "absoluten basics" abfrühstücken...
« Letzte Änderung: 10.06.20 - 08:59:59 von Tode »
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Offline Tode

  • Moderatoren
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.710
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Re: Sametime 11: Moderne Clients aktualisieren Chatverlauf nicht
« Antwort #1 am: 10.06.20 - 08:59:43 »
Was zur Hölle... ich habe mal Settings- Datei für Settings- Datei meines Test- Servers mit der des nicht funktionierenden Servers verglichen... und bei der sametime.ini wurde ich fündig:

Funktionierender Server:

MONGO_COLLECTION=EVENTS

Nicht funktionierender Server:

MONGO_COLLECTION=events

Klar: Die Collection in der MongoDB heisst EVENTS... Und kaum habe ich das korrigiert, tut das Ganze wieder...
Keine Ahnung, wie dieser Wert in die sametime.ini gekommen ist... Aber jedenfalls ist damit der Fall gelöst...
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Offline oliK

  • Senior Mitglied
  • ****
  • Beiträge: 366
Ich spiele gerade mit policyExceptions.xml, da man unter 11.0.1 FP1 wohl explizit für 9er-Clients
die Chatpersistenz ausmachen muss, damit dort wieder das Verteilen von Offline-Nachrichten über die Notes-DB funktioniert.

<PolicyExceptionsRules>
<Rule id="1" weight="10" product="im" client_ids="14AF,130F,14B4,129C">
<Policy id="im.persistentChatEnabled" value="0"/>
</Rule>
</PolicyExceptionsRules>

Ich kann morgen zurückmelden, ob das was bringt.
Aktuell bekommen 9er-Nutzer gar keine Offline-Nachrichten mehr aufgrund eines "Bugfixes".
So schön wie die 11er Version ist, die Transition von 9 zu 11 ist eher holprig.

Offline Tode

  • Moderatoren
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.710
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Ja, den Fehler habe ich bei einem Kunden auch... bin gespannt, ob der Workaround funktioniert.
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Offline Tode

  • Moderatoren
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.710
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Konntest Du das ausprobieren? Weil ich stelle mir vor, dass das auch ein Problem ist, wenn ein 11er Client eine Offline Message an einen 9er schickt: Beim absenden weiss der ja noch nicht, dass der EMpfänger einen 9er verwendet...
« Letzte Änderung: 09.07.20 - 09:21:54 von Tode »
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Offline oliK

  • Senior Mitglied
  • ****
  • Beiträge: 366
Sorry wegen der fehlenden Rückmeldung.
Ich konnte es mit der empfohlenen Anpassung NICHT lösen.
Ticket ging auch wieder zurück an HCL und liegt da jetzt auch gefühlt 2 Wochen.

Es macht auch keinen Sinn, da ja der SENDENDE Client bereits entscheiden muss, ob der Server das in die Notes-Datenbank cached oder nicht. Da interessieren Richtlinien am aktuell genutzten empfangenden Client eigentlich nichts. Habe es auch nur getestet, weil HCL so drauf bestanden hat.
In meinen Augen ist das immer noch ein genereller Bug in der Version. Sie haben einfach das Offline-Messaging von der Domino-DB vollständig auf MongoDB umgestellt (zuvor war es wohl über beide Methoden aktiv und hat für doppelte Offline-Nachrichten gesorgt) und dabei vergessen, dass die V9-Clients ja den Mongo bzw. das Thema Chatpersistenz gar nicht kennen.
Aber ich kann hier nur vermuten was für mich naheliegt.

HCL habe ich das auch bereits so schon geschrieben, aber man merkt, dass beim HCL-Support oftmals das Fachwissen zu den Anwendungen fehlt. Ich bin ja schon immer froh, wenn ich doch mal einen Level-2-Supporter oder gar einen Entwickler am Griff habe, der meine Probleme nicht für surreal erklärt wie es oftmals im Level-1-Support passiert.
« Letzte Änderung: 09.07.20 - 23:42:33 von oliK »

Offline Tode

  • Moderatoren
  • Gold Platin u.s.w. member:)
  • *****
  • Beiträge: 6.710
  • Geschlecht: Männlich
  • Geht nicht, gibt's (fast) nicht... *g*
Kein Problem, bist ja nicht mein persönlicher Support...
Sag mal, hast Du eigentlich schonmal Anthony Payne im HCL Support Forum kontaktiert?
Der ist laut Profil Level 3 Sametime Support bei HCL und hat mir schon einige gute Tipps gegeben...
Vielleicht ist das ja zielführender als sich mittels Support- Case durch die Level zu quälen...
Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

 

Impressum Atnotes.de  -  Powered by Syslords Solutions  -  Datenschutz