AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
23.04.19 - 07:56:08
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 10
| |-+  ND10: Entwicklung (Moderatoren: eknori, fritandr, koehlerbv, Tode)
| | |-+  ODA 10 korrekt im Designer einbinden?
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: ODA 10 korrekt im Designer einbinden?  (Gelesen 658 mal)
HS-Christian
Frischling
*
Offline Offline

Beiträge: 10



« am: 23.10.18 - 08:40:11 »

Notes/Admin/Designer ist 10.0.0 auf Windows 10.1803, Domino ist 10.0.0 auf CentOS 7.5.1804.
ODA von: https://www.openntf.org/main.nsf/project.xsp?r=project/OpenNTF%20Domino%20API/releases/AB716D608E72978685258327005395B3

Habe eine UpdateSite-NSF aus dem Template updatesite.ntf erzeugt, dort die ODA 10.0.0 (diejenige mit XSP-Unterstützung) via site.xml hineingestopft, signiert, sie zur Server notes.ini hinzugefügt. Domino startet mit der frohen Botschaft "HTTP JVM: OpenNTF Domino API is fully operational."
Dann habe ich die ODA mittels der http-URL aus der UpdateSite zum Designer hinzugefügt. Sie wird hier nun als enabled angezeigt unter File/Application/Application Management... In meiner frischen Testanwendung habe ich unter Application Configuration/Xsp Properties/Page Generation den Haken gesetzt im Bereich Library ID für org.openntf... und natürlich gespeichert.
Cleanup, Rebuild, Neustart, alles nochmal geprüft.

Problem: es sind keine Openntf-Klassen verfügbar im Javacode, "import" findet sie nicht.
Hängt vermutlich zusammen mit: im Package Explorer werden keine Openntf-Jars angezeigt (mit der ODA 4.4 auf Domino 9.0.1 waren dort welche zu sehen)

Nachtrag: Anfrage im OpenNTF-Slack ist raus.

Lösung: https://frostillic.us/blog/posts/058650e080e352178525832b00519d2c

Designer - Preferences - Plug-In Development - Target Platform - "... entries at least for ${eclipse_home} and for a directory inside your Notes data dir, here C:\Notes\Data\workspace\applications\eclipse. If they're missing, modify an existing platform or create a new one and add an "Installation"-type entry for ${eclipse_home} and a "Directory"-type one for the eclipse directory within your data dir."

Bei mir fehlte der Eintrag für .../workspace/applications/eclipse, warum auch immer. Es war eine frische V10 Client Installation.
« Letzte Änderung: 23.10.18 - 15:16:55 von HS-Christian » Gespeichert
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: