AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
17.12.18 - 12:44:37
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 6
| |-+  ND6: Administration & Userprobleme (Moderatoren: eknori, Hoshee)
| | |-+  SMTP Protocol Returned a Permanent Error 554 5.7.1 .. Recipient address rejected
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: SMTP Protocol Returned a Permanent Error 554 5.7.1 .. Recipient address rejected  (Gelesen 1029 mal)
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« am: 12.09.18 - 09:15:31 »

Ich hatte mich zuerst etwas gewundert, warum ich keine Reaktion auf mehrere Mails an einen bestimmten Empfänger bekommen habe, bis ich die entspr. Error in meinem Junk gesehen habe. Ich habe versucht die gleiche Mail an andere Empfänger der gleichen Domain zu senden und bekomme immer den gleichen Fehler. Im Log steht dann folgendes:
Code:
11.09.2018 16:57:15   Router: Transferring mail to domain ???-?????.DE (host v08?????.???server.com [??.??.???.???]) via SMTP
11.09.2018 16:57:19   Router: Error transferring message 00522537 via SMTP to v08?????.???server.com  554 5.7.1 <??????????@???-?????.de>: Recipient address rejected: Access denied
11.09.2018 16:57:23   Router: No messages transferred to ???-?????.DE (host v08?????.???server.com) via SMTP
11.09.2018 16:57:27   Router: Transferring mail to domain ???-?????.DE (host v08?????.???server.com [??.??.???.???]) via SMTP

Ich bin mir jetzt auch nicht sicher, ob wirklich die Gegenseite den Empfang ablehnt, oder ob mein eigener Domino die Weiterleitung verweigert.

Ich habe bereits geprüft, ob meine Domain irgendwo geblacklisted ist, habe aber keinen entspr. Hinweis auf Blacklisting gefunden.

Wenn es sicher ist, dass der Zielserver die Mails ablehnt, werde ich versuchen einen passenden Ansprechpartner auf der Gegenseite zu erreichen, was allerdings schwierig sein wird, weil das die Adresse eines Gymnasium ist und ich starke Zweifel habe, dass die da irgendwo nachschaun können.



P.S.: Ich habe die exakt gleiche Mail von einer anderen Domain problemlos senden können. Ich empfange auch regelmäßig Mails vom Empfänger.
Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
Tode
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 6104


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #1 am: 12.09.18 - 10:03:18 »

Mal abgesehen davon, dass 6.5 15 Jahre alt ist: Die Meldung kommt in diesem Kontext definitiv vom Empfänger- Server... Der nimmt den Empfänger nicht an...

Da das für alle Empfänger passiert, könnte ich mir vorstellen, dass in der Empfängerdomäne Sicherheits- Einstellungen aktiviert wurden (z.B. nur verschlüsselte Mails zulassen), die Dein Domino nicht erfüllt, und deshalb bekommst Du einen "Access denied" (StartTLS aktiviert oder SSL zwangsweise aktiviert).
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« Antworten #2 am: 12.09.18 - 10:20:58 »

Es ist ein 9.0.1 ... der Post ist ausversehen im 6er Forum gelandet und ich hab bereits einen Moderator gebeten den Post zu verschieben.

StartTLS ist bei meinem Domino aktiv. Die Frage ist nun, kann ich eigentlich irgendwo sehen, ob mein Domino versucht die Verbindung über StartTLS aufzubauen? Dieses Problem habe ich  tatsächlich nur mir diesem einen Zielserver... ich habe auch schon beim entspr. Webmaster nachgefragt, aber habe wenig Hoffung, dass das zu etwas führt.

Kann ich ggf. auf meiner Seite ein erweitertes Logging/debug Logging aktivieren, um genau zu sehen, was mein Server tut?
Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« Antworten #3 am: 12.09.18 - 12:09:12 »

Code:
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: Attempting to Connect: Host v08?????.???server.com, Port 465, SSL Port 0, Connecting Domain ???.??????.org
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: Connection successful
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 220 dd1?????.???server.com ESMTP
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: CommandEHLO: EHLO ???.??????.org
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-dd1?????.???server.com
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-PIPELINING
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-SIZE 102400000
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-VRFY
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-ETRN
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-AUTH PLAIN LOGIN
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-AUTH=PLAIN LOGIN
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-ENHANCEDSTATUSCODES
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250-8BITMIME
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250 DSN
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: SMTP Authentication is not required by local server.  Username: -blank-
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: Attempting to SubmitMessage:
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: Pipelined commands:
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: MAIL FROM:<????.????@??????.de> SIZE=4254
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: RCPT TO:<??????@???-?????.de>
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: DATA
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: End of pipelined commands
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250 2.1.0 Ok
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 554 5.7.1 <??????@???-?????.de>: Recipient address rejected: Access denied
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 554 5.5.1 Error: no valid recipients
12.09.2018 11:57:14   [287E54:000D-29A318] SMTPClient: CommandRSET:
12.09.2018 11:57:14   SMTP Server [1ACA10:0008-2875A4] Connection from [41.169.124.212] rejected for policy reasons. IP address of connecting host not found in reverse DNS lookup.
12.09.2018 11:57:18   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 250 2.0.0 Ok
12.09.2018 11:57:18   [287E54:000D-29A318] SMTPClient: Attempting to Disconnect:
12.09.2018 11:57:18   [287E54:000D-29A318] SMTPClient: CommandQUIT:
12.09.2018 11:57:22   [287E54:000D-29A318] SMTPClient: ReceiveResponse: 221 2.0.0 Bye
12.09.2018 11:57:22   [287E54:000D-29A318] SMTPClient: Connection terminated successfully

Wobei mir aufgefallen ist, dass in der Zeile bei MAIL FROM eine falsche Absenderadresse gezeigt wird:
MAIL FROM:<frifrzsche....
korrekt wäre MAIL FROM:<fritzsche....

Ich hab keine Ahnung, wo die Absenderadresse so verstümmelt wird, es sieht so aus, als ob die ersten 4 Stellen der Mail adresse mit den ersten 5 stellen der domain überschrieben werden...  Huh
Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
Pyewacket
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 288



« Antworten #4 am: 12.09.18 - 12:24:48 »

Die Absenderadresse dürfte irrelevant sein. Woher soll der Empfänger auch wissen ob die gültig ist.
Dein Problem liegt hier:

Connection from [41.169.124.212] rejected for policy reasons. IP address of connecting host not found in reverse DNS lookup.
Gespeichert

ATOS.org - Feel the music!
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« Antworten #5 am: 12.09.18 - 12:32:01 »

Die Absenderadresse dürfte irrelevant sein. Woher soll der Empfänger auch wissen ob die gültig ist.
Dein Problem liegt hier:

Connection from [41.169.124.212] rejected for policy reasons. IP address of connecting host not found in reverse DNS lookup.


Nein, diese Zeile ist einfach dazwischen gerutscht und hat nichts mit dem Problem zu tun... diese IP ist weder Quell noch Zielsystem im aktuellen Kontext. Da wollte mich wohl mal wieder ein Anwalt über mein Millionenerbe in Kenia informieren...
« Letzte Änderung: 12.09.18 - 12:33:32 von FriFra » Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
Pyewacket
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 288



« Antworten #6 am: 12.09.18 - 12:46:13 »

Ok, hast recht, das passt da nicht rein.
Was ist denn auf der anderen Seite? Bei einem Gymnasium wohl eher kein Domino?

Gespeichert

ATOS.org - Feel the music!
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« Antworten #7 am: 12.09.18 - 13:05:27 »

Was genau auf der anderen Seite läuft, weiß ich nicht. Ich habe eben mal per telnet eine Mail dorthin gesendet und das ging Problemlos:
Code:
220 dd1?????.???server.com ESMTP
EHLO ??????.de
250-dd1?????.???server.com
250-PIPELINING
250-SIZE 102400000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
MAIL FROM:??????@??????.de
250 2.1.0 Ok
RCPT TO:??????@???-?????.de
250 2.1.5 Ok
DATA
354 End data with <CR><LF>.<CR><LF>
test
.
250 2.0.0 Ok: queued as B390A2C000F5

Der einzige Unterschied, den ich sehe ist, dass per Telnet die Zeile "250-STARTTLS" auftaucht und beim Versenden über den Domino nicht.

Ich meine, dass ich StartTLS beim Domino für den Versand aktiv habe: Ports -> Internet Ports -> Mail -> TCP/IP port status: SMTP Outbound : Negotiated SSL
Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
DomAdm
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 92

Ich liebe dieses Forum!


« Antworten #8 am: 12.09.18 - 13:52:32 »

Code:
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: Attempting to Connect: Host v08?????.???server.com, Port 465, SSL Port 0, Connecting Domain ???.??????.org

Das geht zum Port 465.
Und auf welchen Port geht Dein Telnet?
Port 465 sollte nicht mehr verwendet werden:
https://de.wikipedia.org/wiki/SMTPS

Jacob
Gespeichert
FriFra
Senior Mitglied
****
Offline Offline

Geschlecht: Männlich
Beiträge: 378



« Antworten #9 am: 12.09.18 - 14:36:45 »

Code:
12.09.2018 11:57:13   [287E54:000D-29A318] SMTPClient: Attempting to Connect: Host v08?????.???server.com, Port 465, SSL Port 0, Connecting Domain ???.??????.org

Das geht zum Port 465.
Und auf welchen Port geht Dein Telnet?
Port 465 sollte nicht mehr verwendet werden:
https://de.wikipedia.org/wiki/SMTPS

Jacob

Mein Telnet ging auf Port 25 ... Der Domino hatte tatsächlich noch 465 eingetragen. Der Server des Gymnasiums hört auf Port 465, aber sagt nicht, dass er StartTLS erwartet und weist dann alles ab. Anscheinend hatten bisher alle anderen Empfänger-Server 465 aktiv, bzw. komplett aus, so dass es nen Fallback auf 25 gab. Auf jeden Fall ist das Problem jetzt beseitigt Smiley
Gespeichert

Gruß
Michael


IBM Certified Advanced Application Developer (PCLP AD 8.5,8,7,6,5)
IBM Certified Associate System Administrator (CLS SA 8.5)
Domino 9.0.1 (Windows Server 2008)
Inventor of the 00.00.200x?
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: