AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
20.07.18 - 18:13:04
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 9
| |-+  ND9: Administration & Userprobleme (Moderatoren: Axel, Thomas Schulte, koehlerbv)
| | |-+  E-Mail wurde nicht an alle Empfänger versendet und verblieb im "Entwürfe"-Ordner
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: E-Mail wurde nicht an alle Empfänger versendet und verblieb im "Entwürfe"-Ordner  (Gelesen 730 mal)
Chako
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 52



« am: 11.01.18 - 19:07:55 »

Hallo zusammen,

ich habe ein komisches Phänomen bei einem Mailversand.
Da ich schon erfolglos diverse Dokumente und Logs geprüft und Reproduktionsversuche hinter mir habe, seid ihr meine letzte Hoffnung.
Vielleicht ist schon mal einer von euch über so ein Problem gestolpert.

Ich nutze Domino 9.0.1 FP7 und Notes 9.0.1 FP8 Standard.

Ausgangslage:

Eine Anwenderin hat eine Mail erstellt, die Empfängermailadressen in das "An"-Feld (aus einer anderen Mail) reinkopiert und die Mail als Entwurf gespeichert.
Später wollte Sie diese Mail dann an die 35 Empfänger versenden. Dazu klickte Sie auf "senden".
Im Endeffekt kam die Mail dann allerdings nur bei 5 Empfängern an (und für einen davon erhielt sie einen Zustellungsfehlerbericht „Recipient adress recejted: User unkown in relay recipient table“ – ich denke nicht weiter schlimm).
Die E-Mail stand im Client der Anwenderin anschließend nicht unter "gesendet", sondern verblieb weiterhin im "Entwürfe"-Ordner.

Ich habe die Logs ihres Mailhomeservers geprüft.
-> Die Mail ging definitiv nur an 5 Leute raus. An die anderen 30 Empfänger wurde die Mail gar nicht erst verschickt.

---------------------------------------------------------------

So habe ich ihr erstmal geholfen:


Ich habe den Inhalt der Nachricht in eine neue Mail kopiert und diese erfolgreich an die restlichen 30 Empfänger gesendet.

---------------------------------------------------------------

Was ich geprüft habe, um die Ursache für das Problem einzugrenzen:

- Die E-Mailempfängerliste in den Dokumenteneigenschaften sieht "sauber" aus. Keine Sonderzeichen, keine Abnormalitäten.

- Vorhin habe ich auf allen "äußeren" SMTP-Servern die Routertasks gestoppt und die E-Mail, die bei der Anwenderin weiterhin in den Entwürfen stand, nochmal versendet.
Die Mail stand danach korrekt unter „Gesendet“.

Ich habe festgestellt, dass die E-Mail in den Mail.box-DBs der beteiligten Server in 3 Dokumente mit verschiedenen Empfängern gesplittet wird.
Unter Anderem enthielt eines der drei Dokumente die 5 Empfängeradressen, die die Mail damals auch bekommen haben.
Bei dieser Reproduktion hätte also alles geklappt. Im Log ihres Mailhomeservers sah ich, dass alle Empfänger korrekt im Log auftauchten.

Fragen:

Hat jemand von euch eine Idee, warum die Mail bei der Anwenderin nicht im gesendet Ordner auftauchte, sondern unter "Entwürfe" verblieb?
Und warum die E-Mail nur an einen Teil der Empfänger verschickt wurde?  Ahnungslos

Ich verstehe auch nicht ganz, wann Notes eine Mail in verschiedene Dokumente in der mail.box aufsplittet.

Gruß
Chako
Gespeichert

- Ich habe keine Signatur -
Tode
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 6017


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #1 am: 12.01.18 - 09:01:26 »

Witzig... das ist das dritte Mail innerhalb kürzester Zeit, dass ich in verschiedenen Umgebungen dieses Problem sehe.

Die wahrscheinlich Ursache ist -imho- ein Bug im Mailversand des Clients. Ich vermute, dass die 5, die die Mail bekommen haben, mit Ihrer Notes- Adresses angegeben waren, und alle anderen mit einer SMTP- Adresse.

Der Notes- Client macht nämlich beim versenden von Mails folgendes:

1. Mail so wie sie ist an die Notes- Empfänger senden
2. Mail- Content in Mime wandeln
3. Mail an die SMTP- Empfänger versenden
4. versendete Mail speichern.

Wenn jetzt bei 2 eine Mime- Konvertierungs- Meldung kommt (irgendein Zeichen in einem komischen Zeichensatz oder eine horizontale Linie reichen da ja aus), dann kann der Benutzer diese dummerweise abbrechen...

Jetzt passiert folgendes: Die internen Mails sind schon versendet, aber wenn der Benutzer jetzt alles verwirft oder sogar der Client abschmiert beim Versuch der Konvertierung, dann ist weder die Mail gespeichert / in der gesendet Ansicht, noch bekommen die restlichen Empfänger die Mail zugestellt.

In Deinem Beispiel war die Mail ja schonmal als Entwurf gespeichert, und damit "bleibt" sie auch in diesem Status.

Kann es sowas gewesen sein?
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Chako
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 52



« Antworten #2 am: 12.01.18 - 10:17:24 »

Hey Tode,

genial! Ich teile deine grundsätzliche Vermutung!

Vielleicht hängt es wirklich mit der Mime-Konvertierung zusammen.
Bezüglich der Konvertierung kamen nämlich beim Versand zwei Abfragen.

Die 5 Leute, die die Mail bekommen haben, waren extern und haben sie normal per SMTP erhalten.
Es waren keine Internen User und keine Notes-Adressen.

Mit deinem Tipp werde ich mal ausprobieren, was bei einem erneuten Versand der Mail passieren würde, wenn man die Konvertierung abbricht.
Anschließend werde ich berichten.

Gespeichert

- Ich habe keine Signatur -
Chako
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 52



« Antworten #3 am: 25.01.18 - 15:42:38 »

Hallo Tode,

ich habe den Versand verifiziert und du hattest Recht (Router angehalten und geschaut, was so in der mail.box landet).

Vor der Zeichensatzkonvertierungabfrage hat Notes schon Mails ein paar Mails versendet.
Anschließend kam eine Konvertierungsmeldung (UTF-8 oder bester Zeichensatz, etc.).
-> Bricht man diese Meldung ab, verbleibt die Mail in Entwürfe, obwohl sie bereits an einen Teil der Empfänger verschickt wurde.

Damit so ein unvollständiger Versand durch den Abbruch der Zeichensatzabfrage des Users nicht erneut passieren kann, habe ich nun per Desktoprichtlinie eingestellt, dass immer Unicode (UTF-8) verwendet wird.

Gruß
Chako



Gespeichert

- Ich habe keine Signatur -
Tode
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 6017


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #4 am: 25.01.18 - 17:07:24 »

Ja, so haben wir das hier auch gelöst. Damit kann der Benutzer nicht mehr "versehentlich" abbrechen.
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Pfefferminz-T
Gold Platin u.s.w. member:)
*****
Offline Offline

Beiträge: 1016


« Antworten #5 am: 26.01.18 - 08:01:27 »

Ja, ich gebe bei meinen Kunden auch immer die Einstellung in der Desktoprichtlinie vor.
Gespeichert

Grüsse,
Thorsten
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: