AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
23.06.18 - 16:10:26
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 8
| |-+  ND8: Administration & Userprobleme (Moderatoren: Axel, Thomas Schulte, koehlerbv)
| | |-+  Notes- Client hinter Proxy und Newsletter- Mime- Mails...
« vorheriges nächstes »
Seiten: [1] Nach unten Drucken
Autor Thema: Notes- Client hinter Proxy und Newsletter- Mime- Mails...  (Gelesen 1275 mal)
Tode
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 5990


Geht nicht, gibt's (fast) nicht... *g*


« am: 25.10.16 - 12:05:24 »

Wir haben hier eine sehr ungünstige Situation:

Die Benutzer müssen sich für jede Internet- Verbindung am Proxy anmelden.

Kommt jetzt ein Newsletter aus dem Internet mit eingebetteten Bildern, die nachgeladen werden müssen, bekommt der user für jedes einzelne dieser Bilder ein Proxy- Authentication- Popup, das kann auch bis zu 20 Mal sein...

In Version 8.5.3 des Clients war es so, dass der Client pro Domain intern EINEN Browser geöffnet hat, und die Bilder nacheinander geladen hat.
Manche Newsletter hatten die Bilder auf 2-3 Subdomains verteilt, dann kamen -nervige aber akzeptable- 2-3 Meldungen.

Im 9er Client (9.0.1) macht der Client wohl für jede einzelne Resource eine Browser- Session parallel auf (vermutlich um den Ladevorgang zu beschleunigen),
deshalb die Popup- Inflation...

Kann ich ENTWEDER dem Client sagen, er soll nur EINE Browser- Session starten, oder er soll die Credentials "cashen"?
Ich möchte Benutzername und Kennwort nicht in der Arbeitsumgebung hinterlegen, weil es sich hier um das Novell- Kennwort handelt, und wenn der Benutzer sein Kennwort turnusmässig ändern muss, dann würde er sich mit einem falsch hinterlegten / gespeicherten Kennwort jedesmal selbst aussperren, wenn er eine Mime- Mail aufmacht...
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
michael-r
Gold Platin u.s.w. member:)
*****
Offline Offline

Beiträge: 1564



« Antworten #1 am: 15.11.16 - 21:00:48 »

Hallo Tode,

wir mussten bei uns nur den Proxy in der Arbeitsumgebung hinterlegen.
Der Benutzer authentifiziert sich über seine Windows Session/IP am Proxy und Programme müssen sich bei uns dann eigentlich nicht nochmal mit den Benutzercredentials authentifizieren.

Aber wie das im Novell aussieht kann ich nicht sagen. Kommt bestimmt auch auf den Proxy an und was der Unterstützt.

MFG Michael
Gespeichert

Gutierrez
Junior Mitglied
**
Offline Offline

Beiträge: 85


« Antworten #2 am: 15.11.16 - 22:02:20 »

Moin Tode,

also meine Erfahrung ist, dass man sowieso mit dem 9.0.1er und Proxy-Authetication verloren hat.

Bei uns wird jeder Benutzer am Proxy durch seinen Windows-Anmeldenamen und PW authentifiziert. Trotzdem haben wir die Credentials teilweise in dem Location-Dokument hinterlegt. Funktioniert beim Anschauen einer E-Mail auch ganz gut. Der Benutzer klickt auf "Bilder anzeigen", alle Bilder werden nachgeladen.

Jetzt sind aber Benutzer auf die Idee gekommen, eine MIME-Mail, nach dem Lesen, weiterzuleiten. Jetzt poppt wieder diese dämliche Dialogbox hoch und fragt nach den Credentials. Mein Wireshark sagte mir, dass Notes beim Weiterleiten einfach keine Credentials schickt, wenn der Proxy-Server ein "Authentication required" schickt.

//Edit: Das ist meine Erfahrung. Sagt mir, wenn ich mich irre oder was übersehen hab...

Beste Grüße
« Letzte Änderung: 15.11.16 - 22:04:37 von Gutierrez » Gespeichert
Tode
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 5990


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #3 am: 16.11.16 - 09:02:48 »

Danke für die Antworten, aber helfen tun sie mir nicht wirklich. Ich habe ja schon analysiert, was passiert: Der Client macht pro "Element" eine iexplore.exe (bzw. irgendeine dll des Internet Explorers, ist schon wieder zu lange her, als ich das analysiert hatte) auf, und gibt diesem -wie ihr auch festgestellt habt- die Credentials nicht weiter... Deshalb will ich den Client ja "zwingen" nur einen Prozess zu starten, damit eben nur einmal der Prompt kommt.
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Gutierrez
Junior Mitglied
**
Offline Offline

Beiträge: 85


« Antworten #4 am: 16.11.16 - 09:22:22 »

Moin Tode,

hast du mal versucht in dem Location document unter Web-Retriever die Anzahl "Gleichzeitige Web-Retriever" auf 2 zu setzen? Standard ist 15.
Gespeichert
Steven
Frischling
*
Offline Offline

Beiträge: 6


« Antworten #5 am: 06.12.17 - 13:22:35 »

Moin Tode,

also meine Erfahrung ist, dass man sowieso mit dem 9.0.1er und Proxy-Authetication verloren hat.

Bei uns wird jeder Benutzer am Proxy durch seinen Windows-Anmeldenamen und PW authentifiziert. Trotzdem haben wir die Credentials teilweise in dem Location-Dokument hinterlegt. Funktioniert beim Anschauen einer E-Mail auch ganz gut. Der Benutzer klickt auf "Bilder anzeigen", alle Bilder werden nachgeladen.

Jetzt sind aber Benutzer auf die Idee gekommen, eine MIME-Mail, nach dem Lesen, weiterzuleiten. Jetzt poppt wieder diese dämliche Dialogbox hoch und fragt nach den Credentials. Mein Wireshark sagte mir, dass Notes beim Weiterleiten einfach keine Credentials schickt, wenn der Proxy-Server ein "Authentication required" schickt.

//Edit: Das ist meine Erfahrung. Sagt mir, wenn ich mich irre oder was übersehen hab...

Beste Grüße

Hallo zusammen,

wir hatten ebenfalls das Problem, dass beim weilterleiten immer wieder die Dialogbox aufpoppte. Konnten das jetzt aber lösen.

Voraussetzung sind eine aktuelle mail9.ntf (mindestens Feature Pack 8 ) und der notes.ini Parameter KeepReplyForwardMime=1


Nähere Infos unter:
https://www.ibm.com/support/knowledgecenter/SSKTMJ_9.0.1/admin/conf_enable_retain_mime_formatting.html
« Letzte Änderung: 07.12.17 - 13:39:36 von Stefano » Gespeichert
Tode
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 5990


Geht nicht, gibt's (fast) nicht... *g*


« Antworten #6 am: 07.12.17 - 10:55:18 »

Danke für den Hinweis, der hilft aber bei dem Problem überhaupt nicht... Im Gegenteil: Dadurch würden dann beim Empfänger der weitergeleiteten Mail wieder die ganzen Authentications aufpoppen, weil nicht beim "weiterleitenden" in Richtext umgewandelt wird, sondern der MIME- Part beibehalten. Das heisst: Der Empfänger muss wieder alle Remote- Bilder runterladen...
Gespeichert

Gruss
Torsten (Tode)

P.S.: Da mein Nickname immer mal wieder für Verwirrung sorgt: Tode hat NICHTS mit Tod zu tun. So klingt es einfach, wenn ein 2- Jähriger versucht "Torsten" zu sagen...

Mit jedem Tag meines Lebens erhöht sich zwangsweise die Zahl derer...
... denen ich am AdminCamp ein Bier schulde... Wenn ich hier jemanden angehe: Das ist nie persönlich, sondern immer gegen die "Sparwut" der Firmen gedacht, die ungeschultes Personal in die Administration unternehmenskritischer Systeme werfen... Sprecht mich einfach am AdminCamp an, ich zahle gerne zur "Wiedergutmachung" das ein oder andere Bierchen an der Bar
Seiten: [1] Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: