Das Notes Forum

Lotus Notes / Domino Sonstiges => Help-Desk Applikation !!Help!! => Thema gestartet von: FC am 26.08.05 - 12:23:24



Titel: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 12:23:24
Hallo, auch wenn nun das Final-Release 1.10 am Sonntag rauskommt (Gratulation an Euer tapferes Programm) noch ne Frage:

Habe Version 1.0.10.b1 im Einsatz.

Wenn ich den Dispatchagenten manuell starte, dann bekommen die eingetragenen Supporter ne Mail, lasse ich den Agenten regelmäßig autom. laufen, dann werden die Tickets zwar in die neuen Tickets eingestellt, aber die Mail über das neue Ticket kommt nicht ???

Habe ich was vergessen, oder ist das ein Bug ?

Gruß
Djahan


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: Thomas Schulte am 26.08.05 - 13:04:37
Das dürfte ein Rechte Problem sein. Der Agent rennt dann auf dem Server und trägt die Mails direkt in die Mail.Box ein. Kann es sein das dein Server auf der Mail.box keine Rechte hat oder so etwas?


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 13:09:57
Ist der Mailserver selber, auf dem auch !!HELP!! liegt.


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 13:13:58
Hmm hab den Agent mal in "meinem Namen" autom. laufen lassen --> No Mail  :-:


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 13:29:32
Auf dem Server wird folgendes ausgegeben:

AMgr: Agent ('Dispatch' in 'DATABASE\DRS\EDV\HelpDeskDRS.nsf') printing: SPOOFMESSAGEWITHITEM: 4063 on line 14: Database mail.box has not been opened yet


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: eknori am 26.08.05 - 13:41:31
Hast du in den Konfigurationsdokumenten das Doc , wo die mail.box eingetragen ist ?


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 13:45:31
@Ulrich
Sorry, hatte gerade erst mit der Fehlermeldung Dein Posting gefunden:
http://www.atnotes.de/index.php?topic=23345.msg149073#msg149073

Und habe dann gesucht und gesucht, wo ich wohl die mail.box finde.

Ich hätts mir ja eigentlich denken können und gleich bei den Konfigdocs suchen ......

Wir haben natürlich mehrere Mehlboxen.

Tja, irgendwie sind die Konfigdocs auf der einen Seite suuuuper, auf der anderen Seite leider etwas unübersichtlich...

Danke Thomas, danke Ulrich

P.S.: Aber warum klappt es, wenn man den Agenten von Hand startet ?


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: eknori am 26.08.05 - 13:48:23
Zitat
Tja, irgendwie sind die Konfigdocs auf der einen Seite suuuuper, auf der anderen Seite leider etwas unübersichtlich...
Eventuell sollten wir die mal ein wenig kategorisieren ...


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 13:52:04
Gute Idee  ;D

Erleichtert die Konfigbereiche zu pflegen.


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: Thomas Schulte am 26.08.05 - 14:22:13
Sag das mit den Konfigurationsdokumenten mal den Typen von SAP  >:D

Dagegen sind wir Waisenknaben. Aber das mit der Mail.box werden wir beim nächsten Release noch abfangen.

Wenn du das Ding von Hand startest und auf deinem Rechner dann könnte das sein das er nicht auf die ServerMailbox geht sondern auf deine Rechnereigene. Speziell dann wenn du lokal arbeitest. Deswegen hat das da warscheinlich funktioniert.


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: FC am 26.08.05 - 14:28:27
Sag das mit den Konfigurationsdokumenten mal den Typen von SAP  >:D

Obwohl die SPRO ist zumindest SCHÖN gegliedert, finden tut man auch nichts  8)

Gruß
Djahan

R/3 4.7 geschädigt


Titel: Re: autom. Mail an Supporter aus Dispatch Agent geht nicht
Beitrag von: eknori am 26.08.05 - 17:38:30
ich habe das ERRHANDLE in den Functions SpoofMessage und SpoofMessageWithItem in der lib.appl.functions erweitert.
Im Log steht dann eine etwas aussagekräftigere Fehlermeldung, wenn die Konfiguration der MehlDose (mail.box) nicht stimmt.