AtNotes Übersicht Willkommen Gast. Bitte einloggen oder registrieren.
04.08.20 - 10:36:20
Übersicht Hilfe Regeln Glossar Suche Einloggen Registrieren
News:
Schnellsuche:
+  Das Notes Forum
|-+  Lotus Notes / Domino 9
| |-+  ND9: Administration & Userprobleme (Moderatoren: Axel, Thomas Schulte, koehlerbv)
| | |-+  Domino 9.0.1 FP8 Mailanhänge werden zerstört
« vorheriges nächstes »
Seiten: [1] 2 Nach unten Drucken
Autor Thema: Domino 9.0.1 FP8 Mailanhänge werden zerstört  (Gelesen 9880 mal)
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« am: 13.03.17 - 15:35:11 »

Hallo,
habe eben beim Versenden nach extern festgestellt, dass FP8 bei uns die Dateianhänge zerstört. Auf einem 9.0.1 FP4 klappt allerdings alles noch. Intern funktioniert alles aber nach außen werden alle Dateien nicht mehr lesbar. Kdiff zeigt mir auch einen Unterschied aber ich kann es nicht wirklich herauslesen. Hat das noch jemand festgestellt?

Gruß Kristian
Gespeichert

Gruß Kristian
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« Antworten #1 am: 13.03.17 - 15:50:12 »

Na toll...
Vorhin hatte ich Router und SMTP neu gestartet - keine Änderung. Nun den Server neu gestartet und es geht  Huh
Gespeichert

Gruß Kristian
eknori
@Notes Preisträger
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 11429


« Antworten #2 am: 13.03.17 - 16:27:47 »

Definiere "zerstört"

Welchen Client verwendest Du? Web oder Notes Client.?
Gespeichert
eknori
@Notes Preisträger
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 11429


« Antworten #3 am: 13.03.17 - 16:32:39 »

Schneller test mit Client, Traveler, Verse und iNotes. Keine Probleme.
Gespeichert
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« Antworten #4 am: 14.03.17 - 07:47:11 »

Zerstört ist es so, dass Excel sagt, es wäre ein unlesbarer Inhalt. Kdiff zeigt in einer Zeile den Unterschied an aber ich kann nicht erkennen an welcher Position. Es sieht aus, als wenn nur ein Bit umgedreht wäre. Der Notes Client ist in der Version 9.0.1 FP4. Wie gesagt, ging nach dem kompletten Serverneustart alles wieder. Habe absolut keine Logeinträge dazu gefunden und es hat sich nur auf den externen Versand beschränkt.

Bei unserem Mailgateway kam der Anhang auch defekt an. Der Virenscanner hat einen Fehler in der Datei festgestellt. Wäre es nicht nach dem Neustart wieder gegangen, dann hätte ich auf ein Infrastrukturproblem getippt. M. E. kann es nur der SMTP-Prozess gewesen sein. Das wird intern nicht benutzt und es ist der direkte Weg zum Mailgateway. Aber den hatte ich gestern einzeln neu gestartet ...   Ahnungslos

Ich werde heute noch ein paar Tests machen und dann das Server-Update erneut beginnen. Mal sehen, obs klappt...
Gespeichert

Gruß Kristian
Chilli
Frischling
*
Offline Offline

Beiträge: 26


« Antworten #5 am: 14.03.17 - 08:47:53 »

Hallo,

ich habe das gleiche Problem hier auf unserem Domino. Hab letzte Woche FP8 installiert, alles ist glatt durchgelaufen und hat soweit fehlerfrei funktioniert. Am nächsten Tag habe ich dann Rückmeldungen über nicht lesbare PDF-Anhänge erhalten. Also zurück zu FP7HF409 und alles ist wieder ok.

Erst hatte ich den TranMicro Scanmail in Verdacht, es passiert aber auch, wenn dieser nicht läuft.

Folgendes habe ich bis jetzt herausgefunden:
  • Interner Versand funktioniert fehlerfrei
  • SMTP Mails nach extern sind (bei angehaltenem Routertask) in der Mailbox noch ok, am Zielsystem ist der Anhang nicht mehr lesbar

Nach Vergleich der Mail-Quelltexte sieht man, dass die MIME-Parts zweier identischer PDF-Testmails unterschiedlich sind. Irgendwas läuft da schief bei der MIME Konvertierung beim SMTP Versand.

Domino Neustart und Maschine rebooten hab ich schon durch, hat nichts gebracht. Ich werde mir jetzt einmal eine Testumgebung vorbereiten, damt ich das ausgiebig testen kann.

Gilbert
Gespeichert
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« Antworten #6 am: 14.03.17 - 09:06:59 »

Und ich dachte, dass ich mal wieder der Einzige bin. Werde mich auch mal auf die MIME Parameter konzentrieren.
In der FixList vom FP waren 3 Punkte zu MIME aufgeführt. Zum einen auch dieser: http://www-10.lotus.com/ldd/fixlist.nsf/Public/BE7C32A1295CB8BE852580DC005D73DE?OpenDocument
Eventuell ging da ja wa schief...
Gespeichert

Gruß Kristian
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« Antworten #7 am: 14.03.17 - 09:10:13 »

Hallo,

ich habe das gleiche Problem hier auf unserem Domino. Hab letzte Woche FP8 installiert, alles ist glatt durchgelaufen und hat soweit fehlerfrei funktioniert. Am nächsten Tag habe ich dann Rückmeldungen über nicht lesbare PDF-Anhänge erhalten. Also zurück zu FP7HF409 und alles ist wieder ok.

Erst hatte ich den TranMicro Scanmail in Verdacht, es passiert aber auch, wenn dieser nicht läuft.

Folgendes habe ich bis jetzt herausgefunden:
  • Interner Versand funktioniert fehlerfrei
  • SMTP Mails nach extern sind (bei angehaltenem Routertask) in der Mailbox noch ok, am Zielsystem ist der Anhang nicht mehr lesbar

Nach Vergleich der Mail-Quelltexte sieht man, dass die MIME-Parts zweier identischer PDF-Testmails unterschiedlich sind. Irgendwas läuft da schief bei der MIME Konvertierung beim SMTP Versand.

Domino Neustart und Maschine rebooten hab ich schon durch, hat nichts gebracht. Ich werde mir jetzt einmal eine Testumgebung vorbereiten, damt ich das ausgiebig testen kann.

Gilbert

Hattest du das neue Mailtemplate schon benutzt. Bei mir selbst habe ich es aktualisiert. Werde es nun mal mit einer alten Schablone testen...

Gespeichert

Gruß Kristian
manitu
Frischling
*
Offline Offline

Beiträge: 23

+++


« Antworten #8 am: 14.03.17 - 09:56:30 »

Mahlzeit,

ich habe das selbe Problem nach dem Update FP7 -> FP8.

SMTP / Domino / Server Neustart ohne Ergebnis
FP8 deinstalliert - Anhänge bleiben wieder ganz. Ich habe dazu bei der IBM auch schon ein Ticket aufgemacht.

Meine Umgebung: Domino 9.0.1 FP8 unter SuSE Linux Enterprise, Client Notesclient FP7 Windows

Ich werde im nächsten Wartungsfenster einen Server nochmal hochziehen und schauen, was passiert.

Gespeichert
Chilli
Frischling
*
Offline Offline

Beiträge: 26


« Antworten #9 am: 14.03.17 - 09:57:50 »


Hattest du das neue Mailtemplate schon benutzt. Bei mir selbst habe ich es aktualisiert. Werde es nun mal mit einer alten Schablone testen...


Ich hab nach dem Update gleich das volle Programm erledigt, also auch mail9 und pubnames aktualisiert.
Wie gesagt, jetzt muß ich erstmal eine Testumgebung einrichten, da kann ich mich dann auch mit den Schablonen spielen. Das Produktivsystem läuft stabil und wird solange nicht angegriffen.

Gilbert
Gespeichert
eknori
@Notes Preisträger
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 11429


« Antworten #10 am: 14.03.17 - 14:22:34 »

Zitat
Ich habe dazu bei der IBM auch schon ein Ticket aufgemacht.
Auf keinen Fall hier die Nummer veröffentlichen; andere Betroffe könnten sonst darauf referenzieren.
Gespeichert
manitu
Frischling
*
Offline Offline

Beiträge: 23

+++


« Antworten #11 am: 14.03.17 - 15:51:20 »

nur zur Info

IBM hat das Problem bestätigt und arbeitet an einem Hotfix

Vermutlich gibt es hier noch einen Zusammenhang zwischen Anhang zerstören und Disclaimer anbringen - falls also jemand Lust und zuviel Zeit hat, kann er das in seinem Testumfeld ja mal kombinieren und versuchen nachzustellen  Grin

Ansonsten erst einmal Vorsicht walten lassen mit FP8

@eknori: Danke für den Hinweis ...


PS: das Content-Transfer-Encoding wird bei Mails mit Anhang (und Einsatz von Disclaimer?) falsch gesetzt
« Letzte Änderung: 14.03.17 - 16:14:40 von manitu » Gespeichert
khing
Junior Mitglied
**
Offline Offline

Geschlecht: Männlich
Beiträge: 91



« Antworten #12 am: 14.03.17 - 16:02:30 »

Danke für die Info manitu.
Gespeichert

Gruß Kristian
Pfefferminz-T
Gold Platin u.s.w. member:)
*****
Offline Offline

Beiträge: 1137


« Antworten #13 am: 14.03.17 - 16:25:40 »

@Ulrich wahrscheinlich müssen für uns noch Ironie-Tags ins Forum aufgenommen werden...

@Manitu: Wie neulich in einem anderen Thread beschrieben, hilft es wenn sich andere Firmen an einen SPR hinhängen können. Wenn ihr schon einen PMR bei IBM aufgemacht habt, dann ist es für andere Kunden ausreichend, sich an diesen PMR hinzuhängen um die Gewichtung zu erhöhen... beschleunigt also das ganze. Dementsprechend war der Hinweis von Ulrich ironisch gemeint, weil die PMR-Nummer anderen Kunden ein schnelleres und gezielteres Eröffnen eines eigenen PMR ermöglicht.
Gespeichert

Grüsse,
Thorsten
Chilli
Frischling
*
Offline Offline

Beiträge: 26


« Antworten #14 am: 14.03.17 - 16:56:02 »

Wir vewenden zwar keinen Disclaimer, aber standardmäßig eine Mailsignatur (jpeg als Richtext). Vielleicht hängt es auch damit zusammen.

Zur Info:
https://www.vlaad.lv/lotus.nsf/dx/ibm-domin-901-fp8-corrupts-pdf-attachments
« Letzte Änderung: 14.03.17 - 16:59:09 von Chilli » Gespeichert
Chilli
Frischling
*
Offline Offline

Beiträge: 26


« Antworten #15 am: 14.03.17 - 20:57:48 »

Ok, ich habe es jetzt bei mir gelöst. Es war tatsächlich der Disclaimer dafür verantwortlich.

Bei uns war der Disclaimer im Konfigurationdokument aktiviert, er wurde aber nie mit Text befüllt. Nach Deaktivierung und Serverneustart geht es jetzt auch mit FP8!
Gespeichert
schroederk
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 1659

Ich liebe dieses Forum!


« Antworten #16 am: 15.03.17 - 08:10:07 »

So ganz nebenbei.... Wenn man Probleme damit hat Ironie zu erkennen und zu verstehen, könnte es ein frühes Anzeichen von Alzheimer sein.  Cool Grin
Gespeichert

Ich wäre ja gerne weniger egoistisch, aber was hab ich davon?
JayDee
Senior Mitglied
****
Offline Offline

Beiträge: 281


« Antworten #17 am: 15.03.17 - 08:41:20 »

Kann man das Problem so zusammenfassen: es tritt nur auf, wenn serverseitig ein Disclaimer/eine Ausschlussklausel aktiviert ist? Oder auch in anderen Situationen?
Gespeichert

MfG,
Thomas
eknori
@Notes Preisträger
Moderatoren
Gold Platin u.s.w. member:)
*****
Offline Offline

Geschlecht: Männlich
Beiträge: 11429


« Antworten #18 am: 15.03.17 - 11:15:38 »

Vlad hat vom Support ein update erhalten.  MIMEDisclaimersNoEncode=0

https://www.vlaad.lv/lotus.nsf/dx/possible-solution-for-fp8-corrupted-pdfs-doc-files-

Gespeichert
manitu
Frischling
*
Offline Offline

Beiträge: 23

+++


« Antworten #19 am: 15.03.17 - 12:38:18 »

ja ja, so ein Satire / Sarkasmus Tag wäre hier hilfreich gewesen  Grin
manchmal bin ich so naiv ...  Ahnungslos

Der MIMEDisclaimersNoEncode Schalter hatte es mittlerweile auch bis zu mir geschafft.

Hintergrund / Auslöser für den Patch waren wohl Einladungen mit Anhängen an GMail Konten, für die eine Sonderlocke gebaut wurde (ebendieser Schalter). Der wird bei der Installation FP8 standardmäßig aktiv gesetzt (sicherlich gut gemeint), verursacht aber das Transfer-Encoding Problem bei (PDF?) Anhängen.
Gespeichert
Seiten: [1] 2 Nach oben Drucken 
« vorheriges nächstes »
Gehe zu:  


Einloggen mit Benutzername, Passwort und Sitzungslänge

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Prüfe XHTML 1.0 Prüfe CSS
Impressum Atnotes.de - Powered by Syslords Solutions - Datenschutz | Partner: